Content Type HTML 'DIV' tag


#1

Hey guys,

First of all, great job with Vapid! Totally love it! I’m attempting to use it to build my design portfolio.

I’ve noticed that when you place a “html” type content, you get a ‘div’ tag rendered. Is there any way to turn it off?

Thanks!


#2

Hi, @Cosmin

Thanks for the kind words.

I believe you’re referring to the extra div that our current WYSIWG editor, Trix outputs. We agree that it is uneccessary and creates cruft.

We’re looking into implementing Quill soon. Take a look at the discussion here if you’re interested or curious: https://github.com/vapid/vapid/issues/53

Thanks.


#3

Thanks, @Cosmin! I’m looking forward to seeing what you build. Please be sure to share your portfolio with us when you’re done.

Right now, there’s no way to turn off the HTML directive’s <div> and <br> rendering—they’re a byproduct of the WYSIWYG editor we’re using. That said, we’ve heard similar feedback, and are working to [replace the editor with one that outputs <p> tags. That version of vapid-cli should be released this week.

I’ll try and remember to update this thread once the new editor goes live, but please keep an eye on Issue #53 in case I forget.


#4

Thanks, Scott! I’ll try keeping up with GitHub, although I’ve never been active there since I gave up web development before even starting haha.

Will surely share my portfolio when it’s done. At the moment, the WYSIWYG editor kinda keeps me from moving forward since I’m gonna rely on it heavily for building my case study pages.

Anyway, again, great work! I’ve been looking for a simple solution like this for a long time, and Kirby was the closest to Vapid, but still quite complex for what I usually need :slight_smile:


#5

@Cosmin Just published a new release with the new WYSIWYG editor. Thanks again for the feedback.


#6

Amazing news! And thanks for looking out!