DeprecationWarning: String based operators are deprecated

Seeing the following warning message on my CLI after running vapid start .:

$ vapid start .
(node:26922) [SEQUELIZE0003] DeprecationWarning: String based operators are deprecated. Please use Symbol based operators for better security, read more at https://sequelize.org/master/manual/querying.html#operators

I see the same warning message after running vapid deploy .:

$ vapid deploy .
(node:27912) [SEQUELIZE0003] DeprecationWarning: String based operators are deprecated. Please use Symbol based operators for better security, read more at https://sequelize.org/master/manual/querying.html#operators

The good news is that my Vapid site works (i.e.: both commands operate successfully) however, its sure an annoyance seeing that everything else on the CLI seems to work without issue.

I see a possibly similar post here and its related GitHub issue here.

Is this deprecation warning a known issue? If not, I can submit an issue on the Vapid GitHub site.

Thank you!

Thanks for letting me know. I’ll take a look.