Hosting on AWS Lightsail (EC2)

Hello All,

I have been able to deploy a fully functional website running on Vapid using an AWS EC2 server. I am running Debian and have been able to deploy the website. The steps were as follows:

  1. Open a LightSail EC2 instance which comes preloaded with Node.js and Apache
  2. Install Vapid using npm
  3. Upload all your HTML CSS and JS files to the /project/vapid/www directory
  4. Vapid start .
  5. You can now access your website in the adress:3000 port.
  6. So the app didn’t crash when I closed the ssh terminal I used nohup (I feel like there is a better way to do this)

I am stuck at changing the Vapid port from 3000 to 80. I was able to re-direct port 80 to port 3000 and that works, however, I can’t use livereload. This make’s me feel like it is done incorrectly.

So my question is; How do I change the Vapid project’s port from 3000 to 80?

P.S. Is there a better method than using nohup?

1 Like

There is currently no way to change the port that Vapid should be using, but I think that would not be too difficult to implement. I’ll take a look.

Live reload should be enabled when the Node environment is set to development. In the production environment, it is disabled. Do you set NODE_ENV somewhere?

I’m using PM2 to manage the Vapid process, so it runs in the background and automatically restarts when Vapid crashes.