Installation problems


#1

This morning I installed Vapid:

npm install -g vapid-cli
vapid new path/to/my/project/folder
cd path/to/project/folder
vapid start

(I’m using path/to/my/project/folder for this forum post, but I actually used my project folder path.)

I got permissions errors, so I ran the install command again with sudo in front of it, which seemed to work. Entered the folder and vapid start gave me this error:

ERROR: Please install sqlite3 package manually

So I Googled that and tried to install sqlite3 manually:

npm install sqlite3

Which gave me this:

> sqlite3@4.0.2 install path/to/my/project/folder/node_modules/sqlite3
> node-pre-gyp install --fallback-to-build

node-pre-gyp WARN Using request for node-pre-gyp https download
[sqlite3] Success: "path/to/my/project/folder/node_modules/sqlite3/lib/binding/node-v57-darwin-x64/node_sqlite3.node" is installed via remote
npm notice created a lockfile as package-lock.json. You should commit this file.
npm WARN hello-world-vapid@ No description
npm WARN hello-world-vapid@ No repository field.
npm WARN hello-world-vapid@ No license field.

+ sqlite3@4.0.2
added 113 packages from 101 contributors and audited 159 packages in 4.109s
found 0 vulnerabilities

Then I ran vapid start and got the same error:

ERROR: Please install sqlite3 package manually

#2

Hello, I get same issue on Solus, but no error with Ubuntu.

What OS are you use ?


#3

I’m on Mac OS Mojave.


#4

Do you try type “sqlite3” in terminal ?
Output ?


#5

I’m on WSL Ubuntu and have the vapid-cli successfully installed. But I get the please install sqlite3 package manually error as well.

Tried npm install sqlite3.

Error persisted and it didn’t appear that sqlite3 installed.

Installed via: sudo apt install sqlite3. (Shooting in the dark.)

Same error persists.

Since sqlite3 is successfully installed, I thought I’d mark it as manually installed (shooting in the dark again): apt-mark manual sqlite3

Result: sqlite3 was already set to manually installed.

Same error persists.

No clue how to move past this issue…


#6

@paulshryock How did you install Node on our computer? The need to use sudo makes me think it’s a system/permissions issue.

In any case, here are a couple of things to try:

cd path/to/project/folder
npm install
npm start

If that doesn’t work, maybe:

sudo npm install sqlite3
vapid start

ERROR: Please install sqlite3 package manually
Self hosting install errors
#7

I’m seeing this same issue. I keep getting “ERROR: Please install sqlite3 package manually” no matter what. Tried all suggestions in this thread. Any other ideas?


#8

It seems like the common thread here is that most of you are being forced to install vapid-cli with sudo, and that permission errors follow. Or in the case of the SQLite error, it seems to be an issue with the system finding the package, which I suspect is a culprit of sudo as well.

If anyone is up for it, would you mind taking a look at this NPM article, and see if it’s helpful?
https://docs.npmjs.com/getting-started/fixing-npm-permissions


#9

Yes, this fixed issues for me. (OSX Mojave)
I also had to install bcrypt manually in advance.


#10

On Windows 7. After this thread.

vapid start .                                                                                     
                                                                                                    
==> Starting the development server...                                                              
ERROR: SQLITE_CANTOPEN: unable to open database file                                                
npm ERR! code ELIFECYCLE                                                                            
npm ERR! errno 1                                                                                    
npm ERR! vapid-example@ start: `vapid start .`                                                      
npm ERR! Exit status 1                                                                              
npm ERR!                                                                                            
npm ERR! Failed at the vapid-example@ start script.                                                 
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

#11

@watermelon-pixels Is there a “data” folder inside your project? i.e:

/project
/project/www
/project/data

I’ve seen that error before, when it can’t find the “data” folder, thus can’t figure out where to write the “vapid.sqlite” file.


#12

Thank @scott
The “data” is in my project with a “.keep” file in it.


ERROR: SQLITE_CANTOPEN: unable to open database file
#13

Having the same issue. macOS 10.14:

$ vapid start .
ERROR: Please install sqlite3 package manually

data folder exists.

Tried npm i sqlite3 but no change.


#14

@purplespider The data folder response was for a different issue—sorry if that sent you down a rabbit hole. When you originally installed Vapid, were you forced to use sudo?


#15

Don’t believe so. I seem to remember intalling Vapid without issue, just by using npm install -g vapid-cli. Didn’t need to add sudo. Thanks.


#16

@purplespider It might be worthwhile to try deleting your node_modules folder, and then trying another npm start. If this doesn’t work, DM me, and we can arrange a time to do a chat/Hangout.


#17

I looked through that link and wasn’t about to get anywhere. The recomended method links to me Chapter 3 which link me to MacOS instructions which don’t really mention reinstalling. I dunno.

Command line has always be my achilles heel. Every project has simple docs to follow, they always seem to fail, someone smarter than me then connects to my computer and runs waaaay more commands than I’ve ever seen, the problem is fixed. So it goes.


#18

I’m haing the same issue, although i had vapid installed and running smoothly beforehand(only thing i remember doing is installing node 10, which could be the culprit.)
npm start runs fine, but vapid deploy gives the sqlize3 error as well.


#19

Having the same issue too, using Windows 10.
I can verify sqlite3 is installed using npm list sqlite3.


#20

I’ve found that sqlite3 build is not supported by node > 10, as per some threads
Downgrading node did the trick for me!