{{_permalink}} not working

After deploying my site, the links generated by the {{_permalink}} tag no longer work. When I click on a {{_permalink}} generated link, I go to a “page not found” page. I actually have no idea how to go to any page on my site other than the homepage.

For reference, here’s how one link (which works as expected), generated with {{_permalink}}, looks on my local:

And here’s how the same link (which does not work) looks on production:

Figured out a solution for this but still not sure why the way I had it setup wasn’t working. My site’s child pages, generated by a {{#section}} using multiple=true, had an underscore in them (i.e. “section_name”, which worked on local but on production my section pages only gave me a “page not found”. I tried it with a dash and it also worked on local but on production it only worked with the dash and all characters after the dash removed (i.e. “section-name” didn’t work but “section” did).

So if anyone else ever runs into this, just know your section names cannot have an underscore or dash separating multiple words. You just have to string them all together.

@aaron Thanks for letting me know. The sections should allow you to use underscores and dashes. This sounds like a bug. I’ll look into it, and will post back here when it’s fixed.