Self hosting install errors


#1

so I got node updated to the latest v10.11.0 but I still get errors
I installed again >

npm install -g vapid-cli

Received these errors

npm WARN deprecated browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
npm WARN deprecated @types/commander@2.12.2: This is a stub types definition for commander (https://github.com/tj/commander.js). commander provides its own type definitions, so you don’t need @types/commander installed!
npm WARN checkPermissions Missing write access to /usr/local/lib/node_modules
npm ERR! path /usr/local/lib/node_modules
npm ERR! code EACCES
npm ERR! errno -13
npm ERR! syscall access
npm ERR! Error: EACCES: permission denied, access ‘/usr/local/lib/node_modules’
npm ERR! { [Error: EACCES: permission denied, access ‘/usr/local/lib/node_modules’]
npm ERR! stack:
npm ERR! ‘Error: EACCES: permission denied, access ‘/usr/local/lib/node_modules’’,
npm ERR! errno: -13,
npm ERR! code: ‘EACCES’,
npm ERR! syscall: ‘access’,
npm ERR! path: ‘/usr/local/lib/node_modules’ }
npm ERR!
npm ERR! The operation was rejected by your operating system.
npm ERR! It is likely you do not have the permissions to access this file as the current user
npm ERR!
npm ERR! If you believe this might be a permissions issue, please double-check the
npm ERR! permissions of the file and its containing directories, or try running
npm ERR! the command again as root/Administrator (though this is not recommended).

npm ERR! A complete log of this run can be found in:
npm ERR! /home/c554/.npm/_logs/2018-10-03T16_25_23_262Z-debug.log

$ sudo npm install -g vapid-cli

npm WARN deprecated browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
npm WARN deprecated @types/commander@2.12.2: This is a stub types definition for commander (https://github.com/tj/commander.js). commander provides its own type definitions, so you don’t need @types/commander installed!
Killed …] | extract:vapid-cli: sill doParallel extract 1124

Fixed the Error: EACCES: permission denied, access '/usr/local/lib/node_modules' by running
 ls -la /usr/local/lib/node_modules

`id -un`

 sudo chown -R c554 /usr/local/lib/node_modules
Tried installing again and received new errors that I can't seem to figure out

$ npm install -g vapid-cli

npm WARN deprecated browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
npm WARN deprecated @types/commander@2.12.2: This is a stub types definition for commander (https://github.com/tj/commander.js). commander provides its own type definitions, so you don’t need @types/commander installed!
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules/vapid-cli/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})

npm ERR! path …/lib/node_modules/vapid-cli/bin/cli.js
npm ERR! code EACCES
npm ERR! errno -13
npm ERR! syscall symlink
npm ERR! Error: EACCES: permission denied, symlink ‘…/lib/node_modules/vapid-cli/bin/cli.js’ -> ‘/usr/local/bin/vapid’
npm ERR! { [Error: EACCES: permission denied, symlink ‘…/lib/node_modules/vapid-cli/bin/cli.js’ -> ‘/usr/local/bin/vapid’]
npm ERR! cause:
npm ERR! { Error: EACCES: permission denied, symlink ‘…/lib/node_modules/vapid-cli/bin/cli.js’ -> ‘/usr/local/bin/vapid’
npm ERR! errno: -13,
npm ERR! code: ‘EACCES’,
npm ERR! syscall: ‘symlink’,
npm ERR! path: ‘…/lib/node_modules/vapid-cli/bin/cli.js’,
npm ERR! dest: ‘/usr/local/bin/vapid’ },
npm ERR! stack:
npm ERR! ‘Error: EACCES: permission denied, symlink ‘…/lib/node_modules/vapid-cli/bin/cli.js’ -> ‘/usr/local/bin/vapid’’,
npm ERR! errno: -13,
npm ERR! code: ‘EACCES’,
npm ERR! syscall: ‘symlink’,
npm ERR! path: ‘…/lib/node_modules/vapid-cli/bin/cli.js’,
npm ERR! dest: ‘/usr/local/bin/vapid’ }
npm ERR!
npm ERR! The operation was rejected by your operating system.
npm ERR! It is likely you do not have the permissions to access this file as the current user
npm ERR!
npm ERR! If you believe this might be a permissions issue, please double-check the
npm ERR! permissions of the file and its containing directories, or try running
npm ERR! the command again as root/Administrator (though this is not recommended).

npm ERR! A complete log of this run can be found in:
npm ERR! /home/c554/.npm/_logs/2018-10-03T16_30_28_185Z-debug.log

$ sudo npm install -g vapid-cli

npm WARN deprecated browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
npm WARN deprecated @types/commander@2.12.2: This is a stub types definition for commander (https://github.com/tj/commander.js). commander provides its own type definitions, so you don’t need @types/commander installed!
Killed …] / extract:domain-browser: verb gentlyRm don’t care about cont


#2

Any one familiar with this?


#3

@csmith There’s a similar discussion going on over here. Please chime in.


unlisted #4