Vapid installed, but won't run


#1

I’ve Installed Vapid, but can’t run “vapid start”, here’s my command line:

npm WARN deprecated browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.

/Users/bryankearney/npm-global/bin/vapid -> /Users/bryankearney/npm-global/lib/node_modules/vapid-cli/bin/cli.js

  • vapid-cli@0.2.1

#2

@bryandavidk Are you getting an error message? If so, can you please copy/paste more of it, or take a screenshot? Thanks.


#3

Really confused, because I did the same thing on my old laptop and worked perfectly. What’s wrong with Space Grey Mac? npm location?


#4

@bryandavidk Ah, I see now. It looks like your system is having a hard time resolving vapid to /Users/bryankearney/npm-global/bin/vapid.

Did you reference these instructions before setting up Vapid? If so, the problem might be that npm-global is missing a dot before the folder name. i.e., /Users/bryankearney/.npm-global/bin/vapid. If that’s the case, it might be a matter of walking through those steps again.

If you didn’t reference those instructions, and npm-global (minus the dot) is intentional, then you may just need to add export PATH=~/npm-global/bin:$PATH to your .profile (or .bash_profile or .bashrc, whichever you prefer).


#5

Thanks Scott - that was the problem as I expected, yet I really don’t have the CLI skills to do this on my own. I got some help to nano edit my bash_profile and now vapid runs correctly. Thanks!